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1 USABILITY
1.1 IMPROVED GRAPHIC EXPORT (ALL EDITIONS)

Create presentation-quality graphics with customizable export options
You can now easily share and present your graphics in high resolution without loss of information. The
updates to the image export enable you to get quickly get presentation-ready images of your analyses
and layout plots without any extra steps or workarounds (see Figure 1.1.a).

Figure 1.1.a. The Save As button in the toolbar of an analysis window

When saving images of most analysis and layout windows, you can now increase the resolution of
exported raster graphics formats (PNG, JPG, and BMP) (see Figure 1.1.b).

Figure 1.1.b. The Save As dialog box when exporting to raster graphics

In the settings of the Save As dialog, you can choose between on-screen resolution or custom defined
resolution. You can also specify the width or height of the exported image (see Figure 1.1.c).

Figure 1.1.c. Export Settings when using custom output resolution

Most analysis windows also allow export of vector graphics format (SVG) (see Figure 1.1.d). This format
creates images that are scalable and zoomable without loss of quality and can be printed at any
resolution.
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Figure 1.1.d. The Save As dialog box when exporting to vector graphics

A global default preference for raster graphics can also be set in Project Preferences > Graphics (see
Figure 1.1.e).

Figure 1.1.e. The Graphics settings in the Project Preferences

For more information on the limitations of this feature, refer to this Knowledgebase article.

1.2 EXPRESS VIEW (ALL EDITIONS)

Navigate through editors faster to quickly find surfaces, objects, and operands in large files
This new view to the editors greatly improves the speed and responsiveness in exchange for dynamic
functionality. When using the Express View, scrolling editors with many rows is significantly faster
compared to the normal view, so you won’t experience any lag for buffering row data.
This view is available for all main editors, including the Lens Data Editor and the Non-Sequential
Component Editor. While Normal View enables all the editor features, Express View enables only the
essential features to maximize speed. The Express View is therefore recommended for navigating files with
large numbers of surfaces, objects, or operands, as these systems will demonstrate the most noticeable
increase in speed.
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Figure 1.2.a. The Toggle Express View button in the Lens Data Editor

You can easily switch between the two views, either by clicking the Toggle Express View button in the
editor toolbar or typing the shortcut key (see Figure 1.2.a). A global default preference can also be set in
Project Preferences > Editors (see Figure 1.2.b).

Figure 1.2.b. The Editors settings in the Project Preferences

1.3 ZEMAX FILE COLLECTOR (ALL EDITIONS)

Simplify and automate the process of reporting an error to Zemax Support
The Zemax File Collector helps you report crashes or other errors with greater ease. The file collector
creates a diagnostics package that enables Zemax Support to better diagnose and fix any issues you may
encounter.
The tool automatically gathers data and diagnostics files related to your system environment, other
installed software, or currently running processes. You can also provide your own details and
supplementary data related to the crash or error. You can then view all gathered data (see Figure 1.3.a).
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Figure 1.3.a. All gathered files and information in the Zemax File Collector

Potentially sensitive files which may contain specific data about your design are listed separately and can
be deselected if preferred. After that, you easily send the data to Zemax using the Email Technical Support
button.
The Zemax File Collector can be found on the Help tab, in the Utilities group (see Figure 1.3.b).

Figure 1.3.b. The Zemax File Collector button in the Help tab

1.4 POP-OUT EDITORS UPDATE (ALL EDITIONS)

Quickly modify and enter material transmission and index data
The new Transmission and Fit Index Data editors in the Materials Catalog enable you to easily transfer
data to and from the editor and interact with them in a more intuitive way (see Figures 1.4.a and 1.4.b).
Both editors have been updated to have functionality similar to our primary editors, such as the Lens Data
Editor. You can now easily insert and delete rows, copy and paste data, and adjust the window size. Data
is now sorted automatically from lowest to highest wavelengths.
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Figure 1.4.a. The new Transmission Editor in the Materials Catalog

Figure 1.4.b. The new Fit Index Data Editor in the Materials Catalog
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You can access the Materials Catalog from the Libraries tab, in the Optical Materials group (see Figure
1.4.c).

Figure 1.4.c. The Materials Catalog in the Libraries tab

2 SEQUENTIAL TOOLS AND ANALYSES
2.1 MINIMUM AND MAXIMUM ANGLE OF INCIDENCE OPERANDS (ALL EDITIONS)
Simplify your merit function and reduce data entry errors

Using a grid of rays to constrain the angle of incidence on a surface takes up a large portion of the MFE,
especially when there are multiple wavelengths and fields. This process is susceptible to data entry errors.
With the new MNAI and MXAI operands, you can control problematic rays at the edges of the pupil
without the use of macros or compound operands.

Figure 2.1.a. The MNAI and MXAI operands in the Merit Function Editor

This set of new optimization operands traces the marginal and chief rays and reports the minimum or
maximum incidence angle over a range of surfaces (see Figure 2.1.a). For most systems, the problematic
rays are at the edges of the pupil. While limiting the maximum angle of incident is important in on-axis
refractive systems, optimizing on the minimum angle of incident can improve the design of off-axis
systems.

2.2 GHOST ANGLE OF INCIDENCE OPERAND (ALL EDITIONS)
Reduce the impact of ghost reflections in your optical system
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Total internal reflection from ghost reflections is often a significant issue in sensor-based imaging. With
the new GAOI operand you can now control these during design in sequential mode.

Figure 2.2.a. The GAOI operand in the Merit Function Editor

This new optimization operand calculates the angle of incidence (AOI) of a ray at any surface, after a
double-bounce ghost reflection (see Figure 2.2.a). The ghost system that is traced is the same as if it was
created with the Ghost Focus Generator tool.

2.3 DISPLAY BEAM WIDTH IN POP ANALYSES (PROFESSIONAL AND PREMIUM
EDITIONS)
Easily view the beam width of a coherent optical beam

The beam width is now shown directly in the text field below the plot area of Physical Optics Propagation
(POP) analyses, as compared to previously when the value was only available using multiple POPD
optimization operands in the Merit Function Editor (see Figure 2.3.a).

Figure 2.3.a. The Physical Optics Propagation analysis displaying the beam width in X and Y
Copyright © Zemax, LLC 2018. All Rights Reserved.

Rev 1, 08/14/2018

9/25

The calculation of the beam width is based on determining the second moment of a beam. For a Gaussian
beam profile, the second moment equates to the beam radius at the 1/e2 intensity point. The second
moment can be calculated using the POPD operand, data item 23 in X and 24 in Y.
The Physical Optics Propagation analysis can be found in the Laser and Fibers group on the Analyze tab
(see Figure 2.3.b).

Figure 2.3.b. The Physical Optics button on the Analyze tab

2.4 MULTI-CONFIGURATION SUPPORT FOR THE DESIGN LOCKDOWN TOOL (ALL
EDITIONS)

Prepare a sequential optical system with multiple configurations for optomechanical analysis and
production
The Design Lockdown tool now supports converting systems with multiple configurations into real
manufacturing inputs of a production system (see Figure 2.4.a).

Figure 2.4.a. The Design Lockdown tool dialog box

The Design Lockdown tool can be found in the Production Tools group on the Tolerance tab (see Figure
2.4.b).

Figure 2.4.b. The Design Lockdown button in the Tolerance tab

It can also be accessed from the Convert to NSC Group tool located in the Convert group on the File tab.
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3 PROGRAMMING
3.1 RUN WAVEFRONT ANALYSES WITH THE ZOS-API (PROFESSIONAL AND
PREMIUM EDITIONS)

Automate freeform design processes and create visualization routines through the ZOS-API
The ZOS-API can now call the recently added sequential analyses: Contrast Loss Map and Full-Field
Aberration (see Figure 3.1.a).

Figure 3.1.a. The recently added Wavefront analyses: Contrast Loss Map (left) and Full-Field Aberration (right)

The following are examples of the syntax for either analyses.
Contrast Loss Map
•
•
•
•

C#:
ZOSAPI.Analysis.IA_ newWin =
TheSystem.Analyses.New_Analysis(ZOSAPI.Analysis.AnalysisIDM.ContrastLoss);
C++: IA_Ptr newWin = TheSystem->Analyses>New_Analysis(AnalysisIDM::AnalysisIDM_ContrastLoss);
MATLAB:
newWin =
TheSystem.Analyses.New_Analysis(ZOSAPI.Analysis.AnalysisIDM.ContrastLoss);
Python: newWin = zosapi.TheSystem.Analyses.New_Analysis(constants.AnalysisIDM_ContrastLoss)

Full-Field Aberration
•
•
•
•

C#:
ZOSAPI.Analysis.IA_ newWin =
TheSystem.Analyses.New_Analysis(ZOSAPI.Analysis.AnalysisIDM.FullFieldAberration);
C++: IA_Ptr newWin = TheSystem->Analyses>New_Analysis(AnalysisIDM::AnalysisIDM_FullFieldAberration);
MATLAB:
newWin =
TheSystem.Analyses.New_Analysis(ZOSAPI.Analysis.AnalysisIDM.FullFieldAberration);
Python: newWin =
zosapi.TheSystem.Analyses.New_Analysis(constants.AnalysisIDM_FullFieldAberration)
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For more information about these tools, see the ZOS-API Syntax Help (see Figure 3.1.b).

Figure 3.1.b. The ZOS-API Syntax Help dialog box, open to IAS_ContrastLossMap (left) and IAS_FullFieldAberration
(right).

The ZOS-API Syntax Help can be found in the Programming tab (see Figure 1.3.c).

Figure 1.3c. The Programming tab with the ZOS-API Help menu

3.2 USE THE SIMPLIFIED SEQUENTIAL OPTIMIZATION WIZARD WITH THE ZOS-API
(PROFESSIONAL AND PREMIUM EDITIONS)
Build automated optimization routines with the right merit function through the ZOS-API

The simplified Optimization Wizard introduced in OpticStudio 17.5 can now be accessed with the ZOS-API
(see Figure 3.2.a).
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Figure 3.2.a. The Optimization Wizard in the Merit Function Editor

Here are some examples of the syntax.
•
•
•
•

C#:
ZOSAPI.Wizards.ISEQOptimizationWizard2 optWizard =
TheSystem.MFE.SEQOptimizationWizard2;
C++: ISEQOptimizationWizard2Ptr optWizard = TheSystem->MFE->SEQOptimizationWizard2;
MATLAB:
optWizard = TheSystem.MFE.SEQOptimizationWizard2;
Python: optWizard = TheSystem.MFE.SEQOptimizationWizard2

For more information about how to use this new wizard, see the ZOS-API Syntax Help (see Figure 3.2.b).

Figure 3.2.b. The ZOS-API Syntax Help dialog box, open to ISEQOptimizationWizard2
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4 LIBRARIES AND CATALOGS
4.1 LICENSE MANAGER (ALL EDITIONS)
Get the latest License Manager updates

The Zemax License Manager now displays whether a license has expired or if only the support has ended
(see Figure 4.1.a). It also includes improved error checking to prevent softkey license activation and
transfer failures.

Figure 4.1.a. The Zemax License Manager showing key and support expiration dates

These changes are incorporated in OpticStudio as well as the standalone Zemax License Manager. If
you’re hosting an OpticStudio network softkey or network red USB license, update your server to the
latest Zemax License Manager to access this newly enhanced license information.

4.2 MATERIALS (ALL EDITIONS)

Get the latest materials catalogs from Ohara, Redwave, CDGM, Nikon-Hikari, Schott, and AMTIR
The Ohara Materials Catalog has been updated to include five new glasses: S-LAH98, S-LAH99, S-LAL21,
S-NPH7, and S-NBH58 (see Figure 4.2.a). The dPgF value of L-BAL43 has been updated to -0.0043. The
catalog now also contains comments that reflect the material status.
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Figure 4.2.a. The Ohara Materials Catalog

OpticStudio now includes a Materials Catalog from Redwave Glass (see Figure 4.2.b). This catalog includes
four new glasses.

Figure 4.2.b. The Redwave Glass Materials Catalog

The CDGM Materials Catalog has been updated to include the following materials: H-BaK7A, H-ZK7A, HZF1A, H-ZLaF69A, HWS5, and HWS7 (see Figure 4.2.c). The melt frequency and relative cost of H-FK71 and
H-QK1 were updated. The transmission values for H-BaK1 and H-ZK50 were modified. The status of HK9LGT was set to Standard.
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Figure 4.2.c. The CDGM Materials Catalog

The Nikon and Hikari Materials Catalog have been consolidated to form a new Nikon-Hikari Materials
Catalog (see Figure 4.2.d). In the new catalog, the precision of thermal index coefficients of some older
materials has been changed to three significant digits.

Figure 4.2.d. The Nikon-Hikari Materials Catalog

The Schott Materials Catalog has been updated with new transmission data and auxiliary data such as
relative cost (see Figure 4.2.e).
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Figure 4.2.e. The Schott Materials Catalog

The Schott IRG Materials Catalog now contains a new material: IRG27 (see Figure 4.2.f). The most recent
thermal data was also included.

Figure 4.2.f. The Schott IRG Materials catalog

OpticStudio 18.7 also includes a new Materials Catalog from AMTIR (see Figure 4.2.g), containing three
materials. This catalog contains the materials previously included in the Infrared Materials Catalog.
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Figure 4.2.g. The AMTIR Materials Catalog

The Infrared Materials Catalog has had several updates to the reference temperatures and as well as
source references (see Figure 4.2.h). The materials from Schott in this catalog have been set to Obsolete
and Exclude Substitution is selected. Consider using the materials from the Schott Materials Catalog
instead.

Figure 4.2.h. The Infrared Materials Catalog

The UVIR material in the IR Photonics Materials Catalog has been set to Obsolete, as this company no
longer exists (see Figure 4.2.i).
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Figure 4.2.i. The IR Photonics Materials Catalog

You can access the Materials Catalog from the Optical Materials group on the Libraries tab (see Figure
4.2.j).

Figure 4.2.j. The Libraries tab with the Materials Catalog button

4.3 LENSES (ALL EDITIONS)

Get the latest lens catalog from Thorlabs and Edmund Optics
The Thorlabs Lens Catalog has been updated with new lenses (see Figure 4.3.a). The catalog now contains
3114 lenses.
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Figure 4.3.a. The Thorlabs Lens Catalog

The Edmund Optics Lens Catalog has been updated to include their currently available stock lenses (see
Figure 4.3.b). The new catalog has a total of 9299 lenses.

Figure 4.3.b. The Edmund Optics Lens Catalog

You can access the Lens Catalog from the Stock Parts group of the Libraries tab (see Figure 4.3.c).
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Figure 4.3.c. The Libraries tab includes the Lens Catalog button

4.4 TEST PLATES (ALL EDITIONS)

Get the latest test plate list from Sill Optics
Sill Optics removed the Sill Optics-Tools.tpd from the installer and added an updated version of Sill
Optics-Test Plates.tpd (see Figure 4.4.a). Some values of existing test plates have been updated as they
have been remeasured with a new equipment.

Figure 4.4.a. The Sill Optics Test Plates

You can access the test plate lists from the Stock Parts group of the Libraries tab (see Figure 4.4.b).

Figure 4.4.b. The Test Plate Lists button on the Libraries tab
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5 ZEMAX LAB
5.1 FEATURE EXPERIMENT: RETAIN TOLERANCING DATA (ALL EDITIONS)
See what’s coming and test a potential new feature

The Zemax Lab includes a new feature experiment. This feature is likely to change before final
implementation and is not yet documented in the Help Files.
The Retain Tolerancing Data feature increases the capability of the Tolerancing tool, greatly simplifying
post-processing analysis of tolerance data. Entire tolerancing runs can be saved to disk and analyzed
separately, and even analyzed by different machines if needed.
For sensitivity and Monte Carlo analyses, all sampled operand, compensator, and criterion values are
collected and reported in tabular format. The results are displayed in three tabs: Monte Carlo, Sensitivity,
and Summary. The Summary tab contains the results of a tolerancing run in the current format. Statistics
are reported for each column in the output (see Figure 5.1.a).

Figure 5.1.a. The Tolerancing results in tabular format (left), and summary statistics for each operand (right)

Data can be copied from the resulting table and pasted into an Excel or text file. Tolerancing results can
be exported to a binary file, the Zemax Tolerance Data file (*.ZTD). They can also be imported using the
Import Tolerance Data feature. You can enable this feature by selecting the Retain Tolerancing Data
checkbox in the settings of the tool (see Figure 5.1.b).
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Figure 5.1.b. The Tolerancing tool with the Retain Tolerancing Data option selected

The Tolerancing tool with the new Data Retention feature can be accessed from the Feature Experiments
menu in the Zemax Lab group on the Help tab (see Figure 5.1.c).

Figure 5.1.c. The Feature Experiment menu in the Zemax Lab group

Please provide your feedback about this and other feature experiments in the Zemax Forum. We have set
up a new section in the Forum specifically for this purpose. This can also be accessed using the Provide
Feedback button in the Feature Experiments menu. We’d like to know more about what functionality you
would like us to add and how you would want to visualize the data.

5.2 RESEARCH SURVEY (ALL EDITIONS)
Shape the future of Zemax

In this new Zemax survey for OpticStudio 18.7 customers, we're asking for your feedback to help us better
understand your design needs, and the needs of the optical and illumination design industries. We'll use
the results to update our roadmap and plan the development of OpticStudio.
The survey can be found in the Zemax Lab group on the Help tab (see Figure 5.2.a).

Figure 5.2.a. The Research Survey button on the Help tab
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6 BUG FIXES
OpticStudio 18.7 includes the following improvements:
Sequential tools and analyses
•
•
•

•
•
•
•
•

•
•
•

•
•

•

•

Export 2D DXF – The Export 2D DXF function now includes the ability to export the Chip Zone.
Tolerance script – An issue in which tolerancing analysis would not be multi-threaded when
using a tolerance script that writes output data to a binary file has been corrected.
Grid Optimization – An issue with the Grid Sag surface optimization feature experiment in which
the merit function would incorrectly increase during optimization has been fixed. This issue only
occurred when the curvature of the Grid Sag surface was set to be variable and an operand that
depended on the paraxial power of the system was included in the Merit Function Editor.
Convert Code V to OpticStudio – Several updates have been made to the Code V to OpticStudio
macro, including better support for converting systems using private glass catalogs.
Stock Lens Matching – An issue with the Stock Lens Matching tool for systems in mirror space
has been corrected.
Zernike Coefficients vs. Field – An issue with the Zernike Coefficients vs. Field analysis for
systems using Theodolite angles has been corrected.
Biconic Zernike surface – An issue with the effective focal length calculation for systems
including a Biconic Zernike surface has been corrected.
Non-Sequential Component – A new parameter has been added to the Non-Sequential
Component surface, called Back Propagation Distance. If that distance is greater than zero, then
the rays back-propagate before entering the Non-sequential Component.
Petzval radius – An issue with the calculation of the Petzval radius on the image plane when a
material is defined on the image plane has been corrected.
Shaded Model – An issue with the display of user-defined apertures in the Shaded Model when
using non-zero offset values as inputs in the Analysis window has been corrected.
Physical Optics Propagation – Physical Optics Propagation will only be run once by the Merit
Function Editor if the editor contains multiple POPD operands, so long as those operands are on
adjacent lines or are only separated by BLNK operands. Previously, any separation of POPD
operands in the Merit Function Editor would force Physical Optics Propagation to be re-run for
each separation.
Convert To NSC – The Convert To NSC tool now supports conversion of the PRES operand when
converting a multi-configuration sequential file.
Geometric Image Analysis – A note has been added to the comments section of the Geometric
Image Analysis feature for cases in which the chief ray reference has been selected for the analysis
but the chief ray cannot be traced. The note indicates that the vertex reference is instead used in
these situations.
FFT MTF analysis – An issue in which the FFT MTF plot would not correctly update via doubleclicking if the plot previously had Monte Carlo graphics from a tolerance run overlaid on it has
been corrected.
SVIG operand – The ray sampling used for the high precision setting of the SVIG merit function
operand has been increased by a factor of 4.

Non-sequential tools and features
•

Detector surface – An issue with incorrect display of data from a Detector Surface object when
reading data from a ZRD file and applying smoothing to the data has been corrected.
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•

Boolean Native – An issue with ray tracing through the Boolean Native object when one of the
parent objects is a Sphere object has been corrected.

Programming
•
•

•
•

TOLERANCE keyword – An issue in which output from the ZPL keyword TOLERANCE did not
include all tolerance results has been corrected.
Diffraction Encircled Energy – An issue with ENUM values not being available in ZOS-API to
support the highest sampling available for the Diffraction Encircled Energy analysis has been
corrected.
ConfigurationNumber attribute – The ZOS-API attribute “ConfigurationNumber” is now
accessible via COM (for example, using C++ or Python).
SetMulticon data item – An issue with the SetMulticon data item in DDE has been corrected.

Libraries
The Sentinel LDK Runtime version has been updated to version 7.80. There are several minor bug fixes.
The most notable is a fix for long LDK installation times on some systems (up to 10 minutes). This helps
speed up the overall OpticStudio install process.
It also includes patches for several security vulnerabilities originally reported by Kaspersky. It disables the
incoming “Public Networks” port for the Windows Firewall. This limits access to a network license to
internal network users and eliminates a security risk. This can be re-enabled if required.
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